Jump to content


Photo

Here's What You Need to Know About Firefox 57...Nov. 14


  • You cannot start a new topic
  • Please log in to reply
1 reply to this topic

#1 ranchhand

ranchhand

    Moderator

  • Moderators
  • 1,448 posts
  • LocationMidwest

Posted 08 November 2017 - 01:37 PM

Circle Nov. 14 next week on your calendar; Firefox 57 will be released.

Many of the favorite add-ons FF users have will cease to function in the new release. Very Unfortunately, that include favorites such as No Script, No Google Analytics, and Self Destructing Cookies among others.

U Block Origin and Privacy Badger are not listed as legacy in my FF add-ons, so let's hope they will also function in 57.

Self-Destructing Cookies website says it will not be updated, so no hope there.

No Google Analytics website has no information on an updated version, so that leaves us hanging. Google is probably clapping their hands, now millions of users will add to their tracking list.

In the No Script forum, it is posted that the author is currently working on a FF57 version, no release date is given. Good news

I am not clear if the infamous NID and PREF cookies set by Google and used by the NSA for spying purposes will able to be blocked or not in 57. Will have to wait and see what cookie-control add-ons are offered and what they can be configured to do. 

 

As of Nov.14th, I am not entirely clear if older versions of FF will still function for a period of time. I guess we will have to wait and see.

 

https://www.bleeping...ming-next-week/


Fishing Fanatic - gimme a fishing rod, point me North and turn me loose.


#2 ranchhand

ranchhand

    Moderator

  • Moderators
  • 1,448 posts
  • LocationMidwest

Posted 14 November 2017 - 03:17 PM

Well, here we are...Nov.14th.  Interesting that I received a big update yesterday (13th) and it moved me up to vs 56.0.2, and in so doing reset my default home page to the Mozilla website plus some big screens in tabs. So far FF is doing fine, but I notice that in the Help/About Firefox there is a button to update to vs57.0.  I am going to hang loose and not update for now. All my "legacy" add-ons are still working, but I suspect that they will not if I update.

Anyone else using FF experiencing the same thing?


Fishing Fanatic - gimme a fishing rod, point me North and turn me loose.